Cómo solucionar el problema con el editor visual en WordPress 2.8

June 20th, 2009

Tras actualizar varias instancias de WordPress a la versión 2.8, desde muy diferentes versiones, encontré en todos los casos un problema con el editor visual (WYSIWYG).

En todos los casos el problema era el mismo: no aparecían los botones del editor y no se podía editar el contenido, o bien se podría editar pero aparecía en un HTML truncado. El editor en HTML sí funcionaba correctamente. Curiosamente el problema aparecía en Firefox, pero no en otros navegadores, como Safari.

Al parecer (lógicamente) esto no ocurre en nuevas instalaciones.

Así lo puedes solucionar (así lo hice yo):

  1. Accede por FTP para editar el archivo wp-config.php
  2. Añade la siguiente línea al mismo: define(‘CONCATENATE_SCRIPTS’, false );

Listo.

Mi recomendación: No actualices a 2.8 si ya estás en 2.7 o superior. Espera a que salga 2.8.1 o alguna otra versión en la que se haya solucionado el problema.

Otras posibles soluciones.

Otras personas lo han solucionado de diferentes maneras. A mi sólo me funcionó lo que acabo de comentar, pero a continuación expongo algunas otras posibles soluciones, de más light a más radicales:

Solución 1.

  1. Limpiar la caché del navegador.

Sí, solo vaciar la caché del navegador y recargar.

Solución 2.

  1. Ir Herramientas » Acualizar » Reinstalar automáticamente (Tools » Upgrade » Re-install automatically).
  2. Limpiar la caché del navegador.

Solución 3.

  1. Descargar una versión completa de WordPress 2.8 y descompromir en tu equipo.
  2. Eliminar el directorio tinymce en tu servidor: /wp-includes/js/tinymce/
  3. Subir al servidor dicho directorio de la versión que acabas de descargar.

Solución 4.

  1. Descargar una versión completa de WordPress 2.8 y descompromir en tu equipo.
  2. Eliminar todo, excepto wp-config.php y el directorio /wp-content
  3. Subir todo al servidor, excepto wp-config.php y /wp-content
  4. Cargar http://…/wp-admin/upgrade.php

Fuentes:

Este artículo tiene 9 comentarios y hay un blog que lo referencia.

Categorizado en: Desarrollo Web, Software.

Hay 9 comentarios en “Cómo solucionar el problema con el editor visual en WordPress 2.8”

  1. ivanmendoza dijo:

    22 de June de 2009

    Yo lo solucione descargando el zip de wordpress 2.8 y subiendo de nuevo solo la carpeta de tinymce (mcetiny, no recuerdo) que esta dentro de wp-includes

  2. Julio dijo:

    22 de June de 2009

    Gracias por la solucion, a mi me sirvio esta opcion:

    Solución 2.

    1. Ir Herramientas » Acualizar » Reinstalar automáticamente (Tools » Upgrade » Re-install automatically).
    2. Limpiar la caché del navegador.

    cosa de 3 segundos.

  3. Laura dijo:

    28 de June de 2009

    Gracias por el posteo

    Con el define(’CONCATENATE_SCRIPTS’, false ); me funciona perfecto

  4. marliton dijo:

    5 de July de 2009

    Me funcionó la solucion 3, gracias

  5. Elías dijo:

    13 de July de 2009

    solución 3, muchas gracias 😀

  6. 15 de January de 2010

    Pues a mi de momento ninguna me soluciona el problema :((

  7. Juan Manuel Jiménez Sáchez dijo:

    1 de April de 2012

    Colocando en el wp-config.php la linea:

    define(‘CONCATENATE_SCRIPTS’, false );

    Me funcionó perfecto!

    Muchas gracias!!!

  8. 18 de May de 2012

    Muchas Gracias por vuestras aportaciones !

    Tenía el mismo problema en mi Blog WordPress y tras andar buscando y llegar a este Artículo he comprobado que la “Solución 3” funciona 100% correctamente 😉

    Un Saludo desde Barcelona !

  9. 3 de August de 2012

    Gracias por la solucion, a mi me sirvio esta opcion:

    Solución 1.

    Limpiar la caché del navegador.

    Sí, solo vaciar la caché del navegador y recargar.

    cosa de 3 segundos.

Haz un comentario

Referencias en blogs a “Cómo solucionar el problema con el editor visual en WordPress 2.8”

  1. Solución al problema con el editor WYSIWYG en WP 2.8 – EGOLETRISMO

Artículos más recientes

Más recientes